3rd Party Scilab Toolboces

Cross-platform 3rd-Party Scilab Toolboxes

Sometimes maintainers of toolboxes for Scilab do not provide their packages for the desired platform or Scilab version. Because I use Scilab on different platforms I suffer from the lack of binaries for some toolboxes I use. Therefore I recompiled the toolboxes and provide them to the community.

In general toolbox binaries are mainly available for 64-bit Windows, often 64-bit GNU/Linux version but not always. macOS users have the most problems.

Because I use all three platforms I need versions for all these OSes. I use(d) Scilab versions 5.5, 6.0 and 6.1. The following toolbox binaries are available at hani-ibrahim.de/public/scilab/.

Download

Celestlab

CNES Space Mechanics Toolbox for Mission Analysis
Toolbox version: 3.4.0
Scilab version: 6.1
Platform: macOS
Architecture: all
Note: Just a workaround for the error message “*** CelestLab is not available for this version of Scilab (Scilab 6.1.0 or less required)” on Scilab 6.1 for macOS.

CelestlabX

CNES Space Mechanics Toolbox for Mission Analysis (extension)
Toolbox version: 3.3.0,  3.4.0
Scilab version: 6.0, 6.1
Platform: macOS, GNU/Linux
Architecture: x86_64

Distfun

Distribution functions. The statistic package STIXBOX dependes on it.
Toolbox version: 1.1.1
Scilab version: 6.0, 6.1
Platform: macOS, GNU/Linux
Architecture: x86_64

Linear Algebra (linalg)

A collection of algorithms for linear algebra. The statistic package STIXBOX dependes on it.
Toolbox version: 0.4
Scilab version: 6.0, 6.1
Platform: macOS, GNU/Linux
Architecture: x86_64

Scilib-GEO

A collection of functions for use in geodaesie and astronomie.
Toolbox version: 0.6
Scilab version: 6.0, 6.1
Platform: macOS, GNU/Linux, Windows
Architecture: x86_64

slr

A set of miscalleneous tools for scilab. Prettifier for figures and tables.
Toolbox version: 0.2
Scilab version: 6.0, 6.1
Platform: all
Architecture: all

uman

User manual in console + advanced features
Toolbox version: 2.1
Scilab version: 6.0, 6.1
Platform: all (related to macOS)
Architecture: all
Note: Current version 3.0 causes an error on macOS’s Scilab 6.x: regexp: Wrong type for argument #1: String expected. Older version, which do not cause this error, from Atoms’s web site cannot be installed from file due to the lack of DESCRIPTION file. This distribution has one.

xlreadwrite

This toolbox allows to read and write Excel BIFF8 .xls and .xslx files
Toolbox version: 1.2
Scilab version: 6.0
Platform: all
Architecture: all

 

Leave a Reply

Your email address will not be published.